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6.0 INTRODUCTION 

A Web site is a set of linked documents with shared attributes, such as related topics, 
a similar design, or a shared purpose. blacromedia Dreamweaver is a site creation and 
management tool, so you can use it to create complete Web sites, in addition to 
individual documents. 

Getting started in Macromedia Dreamweaver is as easy as opening an existing HTML 
document or creating a new one. Dreamweaver is a professional Web site 
development program. It has been developed to take advantage of the capabilities of 
the latest generation of bro~sers, making it easy for developers to use advanced 
features such as style sheets and dynamic HTML. It has been designed from the 
ground up to work the way professional Web developers /designers do. Dreamweaver 
speeds up site construction and streamlines site maintenance. 

This unit would be very concise in its description of the features of the components of 
Dreamweaver. To elaborate on everything would-be a voluminous task that merits a 
full book for itself. However, this unit will introduce you to the essential elements. 
To get the most out of your Dreamweaver experience, you should understand the 

! 
basic concepts behind the Dreamweaver work area and know how to choose options, 
use inspectors and panels, and set preferences that best fit your work style. 

6.1 OBJECTIVES 

After going through this unit you will be able to: 

+ Understand work area 
Set up the Site Structure 
Design a page in layout view 

. Add contents to Web site 
Insert images / tables to a Web page 

, 6.2 USING DREAMWEAVER 
I p Work Area 

Let us start with a brief overview of the Dreamweaver work area. If you haven't 
already launched Dreamweaver, double-click the Dreamweaver icon on your desktop 
to do so. 

I 



Scripting Languages When you launch Dreamweaver, the following work area items open up. The 
Drearnweaver work area accommodates different styles of working'and levels of 
expertise. Once you get accustomed to keyboard and other shortcuts, you might like to 
work in a totally blank space. The figure below shows different components of the 
work area. 

Document 
window 

Objects Tag 
panel selector 

Floating 
pcmcl 

Launchor 
bar 

Property 
inspecfor 

The Document window displays the current document as you create and edit it. 

The Objects panel contains icons you click to insert objects in your document, and 
to change the way you work in a document. 

Drearnweaver provides many floating panels, such as the HTML Styles panel and 
the Code inspector, which enable you to work with other Dreamweaver elements. 

The Launcher bar contains buttons for opening and closing your most frequently 
used inspectors and panels. 

The Property inspector displays properties for the selected object or text, and lets 
you modify those properties. (Which properties appear in the inspector depends 
on the object active& selected in the documenL) 

You would be well advised to close all the floating panel and options boxes cluttering 
up the work area by clicking on the X on the top right comer of the boxes. To open 
Dreamweaver's windows, inspectors, and panels, use the Window menu. A check 
mark next to an item in the Window menu indicates that the named item is currently 
open (though it may be hidden behind other windows). To display an item that isn't 
currently open, choose the item name from the menu or use its keyboard shortcut. 

Working in Dreamweaver 

Let us now start our journey into the realm of Dreamweaver. We begn with typing in 
a few test lines in our Design view. See how our work area has been divided into two 
windows, one displaying our text and the other displaying the corresponding HTML 
code. 
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Dreamweaver can display a document in three ways: 

as a Design view, 
as a Code view, and 
as a split view that shows both the design and the HTML code. 

View 

' ( Codeldesign view I 
(To change the view in which you are working, select a view in the Dreamweaver 
toolbar.) By default, Dreamweaver displays the Document window in Design view. 
You would be working most of the time in the design view and perform actions such 
as cutting, pasting, inserting pictures, tables and so on. For changing or altering the 
HTML I scripting side, you have to work in code view. 

h1 addition, you can work with Dreamweaver's Design view in two different ways-in 
the Layout view and Standard view. (You select these views in the View category of 
tlw Objectspanel.) In the Layout view you can design a page layout, insert graphics, 
te:xt, and other media. In the Standard view, in addition to inserting graphics text and 
media, you can also insert layers, create frame documents, create tables, and apply 
other changes to your page-options that are not available in the Layout view. In the 
exercise, you will see how to design Web pages in the layout view followed by the 
standard mode. 

Sct up the Site Structure 

Structuring the Web site is the first step towards building the corporate Web site. 
Structuring includes creating a folder, which includes all our picture files, text files 
and database files in their respective folders included in the main folder, which also 
includes the home page. 

To better understand the concept of Structuring the Web Site, you could use the 
Dr.eamweaver tutorial file that is part of the package. In Dreamweaver's main menu 
choose Site > Open Site, then select Tutorial - Dreamweaver. The Tutorial - 
Dreamweaver site links to the Compass Site files located in the Dreamweaver 
4frutorial folder. After selecting the local site, skip to the Create The Site Home Page 
section of the Dreamweaver tutorial. 
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6.3 CREATE THE SITE HOME PAGE 

Now that a site structure is set up for storing pages and assets for the Compass site, 
you'll create the first page--a home page for the site. As you build this page, you'll 
add images, text, and Flash assets; your document will contain the same design 
components as the completed Compass home page. 

Save Your Document 

Begin by saving the document you're working on. 

1. Leave the Site window open, and click the Document window to make it active. 
The Site window remains open in the background. 

2. Choose File > Save. 
3. In the Save As dialog box, select the Compass-Site folder as the location for 

this document. 
4. In the File Name field, type my-CompassHome.html. 
5. Click Save. 

Notice that the document name now appears at the top of the Document window. 

Define the Document Page Title 

Though the document has a file name, notice it is still labelled Untitled Document; 
that is because it needs an HTML document name, or page title. Defining a page title 
helps site visitors identifL the page they are browsing: the page title appears in the 
browser title bar and in the bookmark list. If you create a document without a page 



In this part of the tutorial, you'll title your page: 

1. With the Document window active, choose View > Toolbar if the toolbar isn't 
already visible. 
Dreamweaver's toolbar appears above the Document window 

2. In the Title field, type Compass Home Page; then click in the Document 
window to see the page title updated in the Document window's title bar. 

/-- 

I 
I 3 Save your file. 
! 
I 

I 
I 6.4 DESIGN A PAGE IN LAYOUT VIEW 

You will start your first page while working in Dreamweaver's Layout view. You will 
lay out the page and then insert images and text. The page you complete in this 
section of the tutorial will look similar to the page below. 
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Work in Layout View 

Dreamweaver has two visual design views-Standard view and Layout view. You'll 
start by working in Layout view, which allows you to draw layout cells or layout 
tables into which you can add content such as images, text, or other media. 

In this part of the tutorial, you will lay out the page; in the next section you will add 
content. (Once you're comfortable with these two tasks, you may find it easier to add 

I layout and content together.) 
1. In the Objects panel, click the Layout View icon if it isn't already selected. 

Draw bwut 

D reamweave 

The Getting Started in Layout View dialog box appears and describes the 
Layout view options. 

2. Review the options, then click OK to close the dialog box. 



Scripting Languages 3. In the Objects panel under Layout notice that the Layout options-Draw Layout 
Cell and Draw Layout Tab lea re  now available; these options aren't available 
in Standard view. 

Draw Layout Cells 

In Layout view you can draw layout cells and layout tables to define the design areas 
of a document. This task is easier to accomplish if you prepare a sample of the page 
you're creating before you begin laying out a page. 

Look at the following sample layout to get an idea of the page layout you're creating 
in this section of the tutorial. There's a cell for the Compass logo, a table with three 
cells for site'navigation buttons, a cell for another graphic, and a table for three cells 
that will hold text. 

You will draw tables and cells similar to this layout as you work in your document. 
First, you will draw a layout cell in which you will insert the Compass logo. 

1. Click in the Document window of the my-CompassHome document to make 
the document active. 

2. If they aren't already open, open the following work area tools: 

The Objects panel (choose Window > Objects), which you'll use to add 
objects to your document. 

The Property inspector (choose Window > Properties), which you will use to 
set properties or attributes for objects in your document. If the Property 
inspector isn't already expanded, click the expander arrow in the lower right 
corner so you can see all the property options. 

3. In the Objects panel, click the Draw Layout Cell icon. 

4. Move the pointer to theDocument window; the mouse pointer changes to a 
drawing tool (looks like a small cross). Click in the upper left comer of the 
document, then drag to draw a layout cell. 

When you release the mouse, a layout cell appears in a layout table. 
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'The layout table expands to fill the Document window, and defines the page layout 
tuea. The white rectangle is the layout cell you just drew. You can place additional 
layout celh in the gray area of the layout table. 

ILsize Layout Cells 

To precisely design a page, you can set the size of cells you add in a document. You 
can also reposition cells in the page. 

1. Click the border of the layout cell to select it. 
Handles appear around a selected layout cell: 

-1 2. To resize this layout cell, do one of the following: 

1 In the Property inspector for the layout cell, type 5 10 in the Fixed field to set 
the cell's width to 5 10 pixels, then click in the document to see the cell width 

1 change. 
Note: If you enter a pixel width that is larger than the width of the layout 
table, or that causes the cell to overlap another cell in a layout table, 
Dreamweaver alerts you and adjusts the cell width to a valid width. 
On the right side of the layout cell, drag the middle resize handle to the right 
until the cell is the desired width. When you release the mouse, the cell's 
width is displayed in the column header area along the top of the layout table. 

Adti Multiple Layout Cells 

Nex.t you will add three layout cells below the logo cell you just created. Later you 
will insert the page's navigation buttons in these cells. 

1. [n the Objects panel, click the Draw Layout Cell icon; then hold down the Control 
key (Windows) or Command key (Macintosh). 

2. [n the Document window, position the pointer below the cell you drew for the 
logo; then drag to draw a layout cell. 
Continue to hold the Control key (Windows) or Command key (Macintosh) and 
draw two more layout cells. Your screen should look similar to this. 
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Move a Layout Cell 

If you need to line up the cells next to each other you can resize and move the layout 
cells as you need. You can change the size of a layout cell by using one of its resize 
handles. 

You cannot click and drag a cell to move it to a new position. If you need to move a 
layout cell to reposition it in a document, follow these steps. 

1. Click the border of a layout cell to select it. 
2. To move the layout cell, do one of the following: 

Use the arrow keys. 
Hold down Shifi and use the arrow keys to move a layout cell 5 pixels at a time. 

Group Cells in a Layout Table 

Now you will put the navigation button cells you just created into a single table. 
Grouping the cells into a table enables you to control the.cell spacing and to easily 
move the cells as a group if you want to.change the page layout. You will create a 
table for the navigation buttons that is the same width as the logo cell above it. 

Use Draw Layout Table to group the navigation button images. 

1. In the Objects panel, click the Draw Layout Table icon. 
2. In the Document window, position the pointer at the top left comer of the first 

navigation button cell; then drag the pointer so the table contains the three cells 
and is the length of the logo cell. 

/ 



1. Release the mouse to see the cells erou~ed in a new table. ' 

2. You have created a table that contains three layout cells (the white area in the 
table) and an empty space (the gray area in the table). 

Move the Layout Table 

You can select and move a layout table to other areas in a document. You cannot, 
however, move a layout table so that it overlaps another. 

Next you will move the table you just created a few pixels to the right to offset the 
alignment of the navigation buttons to the logo when they are inserted in the page. 

1. l'n the Document window click the tab on the Layout table to move it. 
2. ]>rag the layout table a few pixels to the right to reposition it, then drag one of the 

table's right resize handles to align the right sides of the logo and navigation 
tlutton layout cells. 

Notice that as you create new tables and cells, gridlines appear outlining the layout 
area. You can use these gridlines to align the layout elements. 

Add :mother Layout Cell 

Next tidd a layout cell for the Learn More About graphic. 

1. In the Objects panel, click the Draw Layout Cell icon. 
2. In the Document window, draw a new cell in the space below the navigation 

button table. 

Your page should look similar to this: 
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1 In the last section you used cells to create a table. Now, you will see hod to start with 
a table and add cells later. 

3bjects panel, click the Draw Layout Table icon. 
pointer to the Document window. In the area below the layout 'cell you 

drag the pointer to the right to align with the right side of the topmost 
'g down to the bottom of the Document window. 

rable 

which you will add text about travel locations. 

, click the Draw Layout Cell icon and move the pointer 'to the 
drew. 

9proxim~tcly one-third the space in the table. 
'the layout cell to select it; then in the Property inspectot's 

,70 to set the cell's width. 
~ l e  cell approximately one-third the space in the table next to the 

ier of the layout cell to select it; then in the Property inspector's 
cype 170 to set the cell's width. 

dst table cell in the remaining space in the table. Resize or move the 
djust the size or position of the cells as needed. 



6.5 INSERT IMAGES 

You will learn two ways to insert images in Dreamweaver--using Dreamweaver's 
main menu and using the Objects panel. 

1. Click anywhere in the logo layout cell (the topmost layout cell). 
Clicking in a layout cell places the insertion point in the cell without selecting the 
cell. 

2. Choose Insert > Image. 
3. In the Select Image Source dialog box, locate the Compass-Site folder and 

navigate to the Assets folder, then the images folder; click the compass - logo.gif 
to select it. 

4. Make sure the Relative To popup menu located at the bottom of the dialog box is 
set to Document, then click Select (Windows) or Open (Macintosh) to select the 
image. 

The image appears in the layout cell. 

5 .  Click anywhere in the Learn More About layout cell to place the insertion point in 
the cell. 

6. In the Objects panel's Common category, click the Insert Image icon. 
7. In the Select Image Source dialog box, locate the Compass-Site/Assets/images 

folder, and navigate to 1earnMareAbout.gif; then click Select (Windows) or Open 
(Macintosh) to select the i q  
The image appears in the layout ceIL 

8. Choose File > Save to save the changes you made to the home page. 



Scripting Languages Create a Rollover Image I 
A rollover image is an image whose display changes when the pointer passes ("rolls") 
over it. You will use Dreamweaver's Insert Rollover Image command to create three 
rollover images for the navigation buttons-Trip Planner, Destinations, and Travel 
Logs. 

A rollover image consists of two images: the image displayed when the page first 
loads in the browser, and the image displayed when the pointer moves over the 
original image. Be sure to use images that are the same size. The first image dictates 
the size of the display, so if the second image is much smaller or much larger, the 
results will look distorted or unprofessional. 

Next, you will add a navigation button with a rollover image to your page. Then you 
will add the other navigation buttons and preview the page in a browser to test the 
rollovers. 

1. In the Document window, click in the first cell of the navigation button table. 
This tells Dreamweaver where you want the image inserted. 

2. To insert a rollover image, do one of the following: 

In the Common category of the Objects panel, click the Insert Rollover Image 
icon. 
Choose Insert > Interactive Image > Rollover Image. 

3. In the Insert Rollover Image dialog box, type planner in the Image Name field. 
This gives the image a unique name, and makes it easily identifiable in the HTML 
code. 

4. In the Original Image field, click Browse; then navigate to MenuTripPlanner.gif 
and click Select (Windows) or Open (Macintosh). 
This tells Dreamweaver which image to display when the page first loads. 

5. In the Rollover Image field, click Browse; then navigate to 
MenuTripPlanner-on.gif and click Select (Windows) or Open (Macintosh). 
This tells Dreamweaver which image to display when the pointer is over the 
original image. 

6. Make sure the Pneload Rollover Image option is selected so that the rollover 
images load when the page loads in the browser, ensuring a quick transition 
between images when a user moves the pointer over the original image. 

7. Click OK to close the dialog box. 
The image appears in the document. 

8. Resize the layout cell to fit the image. 

Create the other Rollover Image 

Now you will add rollover images for the other navigation buttons. 

1. In the Document window, click in the second navigation button cell; then in the 
Common category of the Objects panel, click the Insert Rollover Image icon. 



2. In the Insert Rollover Image dialog box, type destinations in the Image Name field 
to provide the image a unique name. 

Dreamiveaver 

3. In the Original Image field, click Browse, then navigate to and select 
MenuDestinations.gif. 

4. In the Rollover Image field, click Browse, then navigate to and select 
MenuDestinations-on.gif. 

5. Make sure the Preload Rollover Image option is selected, then click OK to close 
the dialog box. 

6. In the Document window, click in the third navigation button cell; then in the 
Objects panel's Common category, click the Insert Rollover Image icon. 

7. In the Insert Rollover Image dialog box, type travellog in the Image Name field to 
provide the image a unique name. 

8. In the Original Image field, click Browse then navigate to and select 
MenuTravelLogs.gif. 

9. In the Rollover Image field, click Browse then navigate to and select 
MenuTravelLogs-on.gif. 

10. Make sure the Preload Rollover Image option is selected, then click OK to close 
the dialog box. 

11. Resize the two layout cells to fit the image. 

Preview Your Document 1 
Yclu cannot view rollover behavior in Dreamweaver's Document window; rollover 
im,ages work only in a browser. However, you can preview the document in 
Dr~eamweaver to see its browser-related functions. You do not have to save the 
document before you preview it. 

1. Press F 12 to see your document in a Web browser. I 

Move the mouse pointer over the rollover images you created to see them 
change. 

2. When you finish previewing the file, close the browser window. 
3. Return to Dreamweaver's Document window and choose File > Save to save the 

changes you made to the home page. 
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6.6 INSERT TEXT 

Now you will add text in the cells of the bottom layout table. 

In Dreamweaver, you can type content directly into a layout cell, or you can cut and 
paste content from another document into a layout cell. In this unit, you will add text 
to the layout cell by copying and pasting content from an existing text file to a layout 
cell. 

I .  Choose File > Open; then, in the Compass Site folder. o ~ e n  DW4 HomeText.txt. I . - - a  

The ~ ~ 4 - ~ o m e ~ e x t . t x t  document opens in a new   ream weaver Document 
window. 

2. In DW4-HomeText.txt select the first two lines of text, "Fly Fishing" through 
"ravioli." 

3. Choose Edit > CODV to c o ~ v  the text. 1 
n 4 , . ~ - -  ~ 

4. In the my-CompassHome document, click in the first layout cell in the text- 
description layout table. 

5. Choose Edit > Paste to paste the text into the layout cell. I 
6. In DW4 ~ome~ext.txtselect the next two lines of text, "Level 5 Rapids" through 

"~iberia." 
7. Choose Edit > Copy to copy the text. 
8. In the my-CompassHome document, click in the second cell in the text I 

description layout table. 
9. Choose Edit > Paste to paste the text into the layout cell. 
10. In DW4-HomeText.txt select the last two lines of text, "Puget Sound Kayaking" 

through "Puget Sound." 
I I .  Copy the text, then paste it in the third cell in the layout table. 
12. Close DW4-HomeText.txt, then click in the my~CompassHome.html to make it 

the active document. 

Format Text 

You can format text in the Document window by setting properties in the Property 
inspector. First, select the text you want to format, and then apply the changes. You 
will change the font type and size ofthe text. 

I .  If the Property inspector isn't open, choose Window > Properties. 
2. In the first text description layout cell, select all the text from the word "Fly," 

through the last word "ravioli." 
3. In the Property inspector's second Format pop-up menu, which currently reads 

Default Font, select Verdana, Arial, Helvetica, sans-serif. 
4. In the Size pop-up menu, select 2. 

The text in your document automatically updates to reflect the changes. 
5. Repeat the above steps to select and format the text in the other two text- 

description layout cells. 

Apply Color and Style 

Now you will apply additional formatting changes to the text such as changing the 
color and style to create heading text. 

I .  In the first text description layout cell, select the heading text from the word "Fly" 
through the word "Mountains." 

2. In the Profirty inspector, click the color picker; then move the eyedropper to the 
Learn More About image in the document window and select the brown color of 
the text in the image. 

3. Still in the Property inspector, click the B icon to apply bold style to the text. 



4. Repeat the above steps to apply color and style to the heading text in the other text 
description layout cells. 

5. Press F12 to preview your page in a browser. 

Your page should look similar to the page below. I 

Fly ~lshlng In the Level 5 Itapldr! Pupet sound Kbyaklng 
Rocky Mountains Put your helmet on andone week of ocean 
Yw'll get a ss&soneel qrab vow wetsuit It's keakino in the Puoet 
oulde and iotI of bme to conclue? Sound. 
dehydratad ravioli. Siberia. 

Notice the text. There is little separation between text in one layout cell and the 
next, especially between the second and third cells. You will fix that in the later 
part of the unit. 

6. Close the browser window, then click in the Document window to make it active. 

6.7 WORK IN STANDARD VIEW 

Layout view is helpful for laying out Web pages. Though you can adjust most of your 
(design elements in Layout view, certain changes must be completed in Standard view. 
When you switch to Standard view, you will see how Dreamweaver uses tables to 
create your page structure. The Layout tables in Layout view are <table> tags in 
Standard view. 

Now you will learn how to work with tables to continue fine-tuning your design. First, 
you will switch to Dreamweaver's Standard view. 

In the Objects panel, click the Standard View icon. 
'Your page should look similar to the screen below. 

I : 
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Scripting Languages . Set Cell Properties 

Cell height determines the height of the space within a cell row. Notice the space 
around the Compass logo. You want to remove the extra space between the logo and 
navigation buttons. 

1. Click anywhere in the blank area of the cell containing the Compass logo image 
(but not the image itself). 

2. In the cell Property inspector, in the H field (height), that currently contains a 
value, delete the value. 

3. Still in the Property inspector, click the Bgcolor box icon located in the bottom 
area of the Property inspector; then use the eyedropper to select black. 
The background color is applied to the cell. 

4. Click anywhere in the Document window to see the change. 

Selecting a Table 

Next you will adjust the space in the navigation button table. The easiest way to select 
a table in Standard view is by using the tag selector, which displays HTML tags of 
elements in the document. 

You will use the tag selector to select the table containing the navigation buttons. 

1. Click in the cell that contains the Trip Planner image. 
. Notice the tag selector at the bottom left of the Document window. 

Note: The tags in your tag selector may vary based on the number of tables you 
created while in Layout view. 

2. In the tag selector, click the rightmost <table> tag. 
In the Document window a border appears around the navigation button table, and 
the Property inspector now reflects properties for a table. 

~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ ~ $ ~ ~ . . . . . . . . . . . .  " .... ""'"... .'.".."-3-"." ... "',...%,. "."."" buget sound Kayaking i 
Hountsins but p w  M e t  M and @ne w w k  of ocean i 
3ouYI get a seasuned guidabrab your wetsuit. It's timebyating in the P u e t  
@no lots of clehyckaled PO conaucf Obchb. .%no. i 

Set Table Properties 

Now you will use the table Property inspector to clear the extra space in the 
navigation buttons table and to add a background color in the table. 

1. In the Property inspector, click the Clear Row Heights icon. It is the top left 
button in the lower half of the Property inspector. 
The extra space is removed from the table. 

2. Still in the Property inspector, click the BgColor color box icon, then use the 
i 
8 , 188 

eyedropper to select the color black. 



The black background color is applied to the navigation buttons table. 

1 
Add Cell Padding 

The Site window now appears with two views of your local site: on the left is a site 
map, which graphically represents the current structure of the Compass site (with 
m y - ~ o i h $ t s s ~ m ~ . h t f n l  agthe home page), and on the right is a list of the local 
folder's continis. 

Dreamweaver 1 

Next, you will make changes to the cells that contain text. As you can see, the text is 
too close to the edges of the cells. You will add padding to the cells to leave room 
between the text and cells. 

1. Click in the first cell in the text description table. 

2. In the tag selector, click the rightmost <table> tag to select the table. 

3. In the Property inspector's CellPad field, type 10 to add 10 pixels of space 
I 

between the text and the table cells. 
L 

4. Click anywhere in the Document window to see the changes. 
I 

I 5. Save your document. 

6.8 VIEW THE SITE FILES 

To see a high-level representation of the structure of a local site, you use 
Dreamweaver's Site Map view. You can also use the site map to add new files to the 
site, to add, remove, and change links, and to create a graphic file of the site that you 
can export to and print from an image-editing application. 

The site map always displays the home page for a site at the top of the map; below the 
home page you can see which files the home page links to. 

There are a number of ways to define a site's home page. The easiest way to set a 
home page is by using the context menu within the Site window. 

1. Click the title bar of the Site window to make it active. (If the Site window is not 
visible, choose Window > Site Files.) 

2. In the Site window's Local Folder list, right-click (Windows) or Control-click 
(Macintosh) the my~CompassHome.html document; then in the context menu, 
choose Set as Home Page. 

3.4 'Click the Site Map icon in the top left area of the Site window; then in the Site 
' Map pop-up menu, select Map and Files. 

i 

Site Map icon 
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The my~CompassHome.htm1 page currently has no links. You will add links to this 
page in the next section of this unit. 

Leave the Site window open for now, so that you can see how the site map gets 
updated as you add links to the home page. 

6.9 LINK YOUR DOCUMENTS 

Images in the top area of the Compass home page guide visitors to specific pages on 
the site. Now you will add links for the navigation buttons. 
You will see that there are a number of ways to create links using Dreamweaver. First, 
you will add a link from the Trip Planner image to the TripPlanner.htm1 page using 
the Property inspector. 

1. In the Site window, double-click the icon for the my~CompassHome.html file in 
either pane. 
The my CompassHome.html file becomes the active window. 

2. In the ~ocument  window, click the Trip Planner image once to select it. 
3. Choose Window > Properties to open the Property inspector if it isn't already 

open. 
The Property inspector displays information about the selected image. 

Note: The Link field contains a number sign (#), often referred to as a null or 
"dummy" link, created when you inserted the rollover image. Do not remove this 
character. It will soon be replaced with the file name of the document you link to. 

4. In the Property inspector, click the folder icon to the right of the Link field. 



5 .  In the Select File dialog box, browse to the Compass-Site folder and then to 
DW4-TripPlanner.htm1; click Select (Windows) or Open (Macintosh) to select 
the file to open when the Trip Planner button is clicked. 
The file name appears in the Link field of the Property inspector. Now you will 
add a link to the Destinations image using the Property inspector and the Site 
window. 

6'. Click the title bar of the Site window to make it active, or choose Window > Site 
Files. Resize your Document window, if necessary, so that you can position the 
left side of the Document window and the Site window side by side. 

7. In the Document window, click the Destinations image to select it. 
8. In the Property inspector, click the Drag to File icon (located to the right of the 

Link field), then drag the pointer to the Site window and in the Local Folder List, 
point to the file DW4-Destinations.htm1. 

I 

The file name appears in the Link field in the Property inspector for the products 
image. 

9. Click the Site Map icon in the Site window. The site map gets updated to reflect 
the link you just added. 

A plus (+) sign next to any file in the site map indicates that the file contains links 
to other documents. Click the plus sign to expand the site map to display the 
associated files; click the minus (-) sign to collapse the site map. 
Next, you will add a link for the Travelogs image. 

10. In the Document window, click the Travelogs image to select it. 
1 1. In the Property inspector, drag the Point-to-~ile icon to the Site window, and point 
. to the file DW4-Travelog.htm1. 
12. Choose File > Save to save the changes you have made to the home page. 

Test Your Page 

You cannot test your links in Dreamweaver; you must check your links in a browser 
to make sure the pages operate as you expect. 

1. Press F12 to preview the page in a browser. 
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Click the navigation buttons to check your links. Click your browser's back 
button to return to your home page. 

2. When you are finished testing your page, choose File > Close to close the page. 

Check Your Progress 1 
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2. What do you mean by Roilover image and hi;& d o  cc;u crc;nrc r~iic? 

................................................... * . . : _ / , . .  . . . . . . . . . . . . . . . . . . . . . . . . . . .  

.......................................................................................... 

6.1 0 SOLUTION'sI ANSWERS 

Check Your Progress 1 

1 .  a. Layout View - you can design page layout, insert graphics, and other 
media. 

b. Standard View - in addition to inserting graphics text and media, you can 
also insert layers, create frame documents, create tables, & other options 
not in layout view 

2. A rollover image is an image whose display changes when the pointer passes 
("roll") over it. A rollover image consists of two images - the image displayed 
when the page first loads in the browser and the image displayed when the 
pointer moves over the original image. To create a rollover image, do the 
following: 

In the common category of the object panel, Inse~.t Rollover Image Icon. 
Choose Insert > Interactive Image > Rollover Image. 
Insert the Insert Rollover Image Dialog box, type name of the Image in 
Image Name Field. 
In the original Image field, select the image to display when the page 
loads. 
In the Rollover Image field, select the Image to display when the mouse 
pointer is over the original Image. 
Preload Rollover Image should be selected to load the rollover image 
when the page when the page is initially loaded to avoid delays. 
Click OK to close the dialog box. 

I 
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